45 lines
1.6 KiB
Makefile
45 lines
1.6 KiB
Makefile
# Created by: johan <johan@nosd.in>
|
|
# net-mgmt/webhook/Makefile 2024-09-21 08:47:42Z
|
|
|
|
PORTNAME= webhook
|
|
PORTVERSION= 2.8.1
|
|
PORTREVISION= 1
|
|
CATEGORIES= net-mgmt
|
|
|
|
MAINTAINER= johan@nosd.in
|
|
COMMENT= Easily create HTTP endpoints (hooks) on your server, which you can use to execute configured commands
|
|
WWW= https://github.com/adnanh/webhook
|
|
|
|
LICENSE= MIT
|
|
|
|
USES= go
|
|
USE_GITHUB= yes
|
|
GH_ACCOUNT= adnanh
|
|
GH_TUPLE= \
|
|
clbanning:mxj:v1.8.4:clbanning_mxj/vendor/github.com/clbanning/mxj \
|
|
dustin:go-humanize:v1.0.0:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
|
|
fsnotify:fsnotify:v1.4.2:fsnotify_fsnotify_1/vendor/gopkg.in/fsnotify.v1 \
|
|
fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/vendor/github.com/fsnotify/fsnotify \
|
|
ghodss:yaml:v1.0.0:ghodss_yaml/vendor/github.com/ghodss/yaml \
|
|
go-check:check:41f04d3bba15:go_check_check/vendor/gopkg.in/check.v1 \
|
|
go-chi:chi:v4.0.2:go_chi_chi/vendor/github.com/go-chi/chi \
|
|
go-yaml:yaml:eb3733d160e7:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
|
|
gofrs:uuid:v3.2.0:gofrs_uuid/vendor/github.com/gofrs/uuid \
|
|
golang:net:c0dbc17a3553:golang_net/vendor/golang.org/x/net \
|
|
golang:sys:04cbcbbfeed8:golang_sys/vendor/golang.org/x/sys \
|
|
gorilla:mux:v1.7.3:gorilla_mux/vendor/github.com/gorilla/mux \
|
|
kr:pretty:v0.1.0:kr_pretty/vendor/github.com/kr/pretty
|
|
|
|
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
|
|
|
|
USE_RC_SUBR= webhook
|
|
|
|
ETCDIR= ${PREFIX}/etc/webhook
|
|
|
|
post-install:
|
|
${MKDIR} ${STAGEDIR}${ETCDIR}
|
|
${INSTALL_DATA} ${FILESDIR}/webhook.yaml.sample \
|
|
${STAGEDIR}${ETCDIR}/webhook.yaml.sample
|
|
|
|
.include <bsd.port.mk>
|