47 lines
2.0 KiB
Makefile
47 lines
2.0 KiB
Makefile
# $FreeBSD: head/sysutils/postfix-log-parser/Makefile 517745 2021-02-15 15:10:39Z yo000 $
|
|
|
|
PORTNAME= postfix-log-parser
|
|
PORTVERSION= 1.4.5
|
|
DISTVERSIONPREFIX=v
|
|
PORTREVISION= 1
|
|
CATEGORIES= sysutils
|
|
|
|
MAINTAINER= johan@nosd.in
|
|
COMMENT= Parse postfix log, and output json format
|
|
|
|
LICENSE= BSD3CLAUSE
|
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
|
|
|
USES= go
|
|
GO_PKGNAME= github.com/yo000/postfix-log-parser
|
|
GO_TARGET= postfix-log-parser/main.go:postfix-log-parser
|
|
|
|
USE_GITHUB= yes
|
|
GH_ACCOUNT= yo000
|
|
GH_PROJECT= postfix-log-parser
|
|
|
|
GH_TUPLE= \
|
|
beorn7:perks:v1.0.1:beorn7_perks/vendor/github.com/beorn7/perks \
|
|
cespare:xxhash:v2.1.1:cespare_xxhash_v2/vendor/github.com/cespare/xxhash/v2 \
|
|
golang:protobuf:v1.5.2:golang_protobuf/vendor/github.com/golang/protobuf \
|
|
golang:sys:59db8d763f22:golang_sys/vendor/golang.org/x/sys \
|
|
inconshreveable:mousetrap:v1.0.0:inconshreveable_mousetrap/vendor/github.com/inconshreveable/mousetrap \
|
|
matttproud:golang_protobuf_extensions:v1.0.1:matttproud_golang_protobuf_extensions/vendor/github.com/matttproud/golang_protobuf_extensions \
|
|
prometheus:client_golang:v1.11.0:prometheus_client_golang/vendor/github.com/prometheus/client_golang \
|
|
prometheus:client_model:v0.2.0:prometheus_client_model/vendor/github.com/prometheus/client_model \
|
|
prometheus:common:v0.29.0:prometheus_common/vendor/github.com/prometheus/common \
|
|
prometheus:procfs:v0.6.0:prometheus_procfs/vendor/github.com/prometheus/procfs \
|
|
protocolbuffers:protobuf-go:v1.26.0:protocolbuffers_protobuf_go/vendor/google.golang.org/protobuf \
|
|
spf13:cobra:v1.1.3:spf13_cobra/vendor/github.com/spf13/cobra \
|
|
spf13:pflag:v1.0.5:spf13_pflag/vendor/github.com/spf13/pflag \
|
|
tabalt:pidfile:v1.1.0:tabalt_pidfile/vendor/github.com/tabalt/pidfile
|
|
|
|
USE_RC_SUBR= postfix-log-parser
|
|
|
|
USE_RC_SUBR= postfix-log-parser
|
|
|
|
pre-test:
|
|
${SETENV} GOPATH="${WRKDIR}"
|
|
|
|
.include <bsd.port.mk>
|